WordPress 技巧:禁用 WordPress 主题插件自动更新

随着 WordPress 的不断更新,官方早在 3.7 的版本中就添加了 WordPress 自动更新的功能,考虑到很多朋友在使用很早以前的 WordPress 主题和插件,也许会造成后台的错误提示或者前台网页出错,所以周良这里分享一下禁用 WordPress 自动更新的几种方法。

第一种方法:通过 wp-config.php 屏蔽

代码如下:

// 禁用 WordPress 自动更新
define( 'WP_AUTO_UPDATE_CORE', false );

把这段代码加到 wp-config.php 文件中即可禁用WordPress的自动更新。

第二种:FTP 设置文件夹权限为不可写

如果你打算永远不升级你的 WordPress,那么我建议你可以在你的服务器中把WordPress文件夹给设置「不可写」权限,这样不仅可以禁用自动更新,还可以防止WordPress系统文件被恶意PHP代码感染。(至于如何设置文件夹权限,各位自行Google 吧。)

46 条评论 / 发表评论

  1. 我博客有好多个, 很多有时忘了去手动更新, 这时自动更新就能起到不错的作用

  2. 我博客有好多个, 很多有时忘了去手动更新, 这时自动更新就能起到不错的作用

    1. vps文件权限、wp-config.php设置,都是可以影响的。我个人感觉这个自动更新就是鸡肋

    1. vps文件权限、wp-config.php设置,都是可以影响的。我个人感觉这个自动更新就是鸡肋

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注